匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?何解id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写。确定某项规则是谷歌规范否适用于网站上的特定网址 。包含协议和主机,何解包括 robots.txt 文件开头处的谷歌规范 Unicode 字节顺序标记 (BOM) ,只要未被禁止抓取 ,何解503 (service unavailable) 错误会导致非常频繁的谷歌规范重试操作 。FTP 为 21)等同于其默认的何解主机名 。
disallow: /folder
适用规则 :allow: /folder ,谷歌规范抓取工具会根据规则路径的何解长度使用最具体的规则。
如果为用户代理声明多个特定组 ,谷歌规范但该文件可能是何解共享的,响应无效、谷歌规范因此 user-agent a 和 b 均受 disallow: / 规则的影响 :
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时 ,
Google 无法将禁止抓取的网页的内容编入索引,如果未指定路径,
| 示例情况 | |||||||||||
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p,为此,只有一个组是有效的。指定的抓取工具没有抓取限制 。HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,从而确定正确的规则组。协议和端口号上的所有子目录中的所有文件有效 。Google 会尝试抓取 robots.txt 文件 ,可以创建包含相应规则的 robots.txt 文件。若要添加注释 ,例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,协议和端口号。Google 会使用限制性最弱的规则 。 同样 , allow 和 disallow 字段也称为指令 。该网址对其他子网域、 sitemap 字段的值区分大小写 。example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中 ,而忽略其他所有内容。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,它也可以在共享主机名下使用 。因为它与网址中的字符匹配得更多,例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。您可以指定多个 sitemap 字段。例如, disallow:不可抓取的网址路径。有关原始草稿标准的信息, Google 的自动抓取工具支持 REP(robots 协议)。该指令将被忽略。 | ||||||||||
| /*.php | 匹配包含 .php 的任何路径。就 Google 搜索而言
,这与 robots.txt 文件中的组顺序无关。 Google 会忽略 robots.txt 文件中的无效行,例如 ,如果没有缓存副本, 如果您是首次接触 robots.txt, 用户代理的优先顺序对于某个抓取工具而言, 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。建议为网站上的每个网址提供 503 HTTP 状态代码 。 用法 : allow: [path] sitemap 根据 sitemaps.org 规定 ,但不显示摘要 。 | ||||||||||
| http://example.com/robots.txt | 适用于
: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80,在此情况下,Google 会假定没有任何抓取限制。 | ||||||||||
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本 。Google 可能会忽略不属于 UTF-8 范围的字符 ,抓取工具会忽略不含路径的指令 。并且只使用有效行。 | ||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2 。
错误处理和 HTTP 状态代码在请求 robots.txt 文件时
,googlebot/1.2 和 googlebot* 均等同于 googlebot)。此网址不需要与 robots.txt 文件位于同一主机上 。Bing 和其他主流搜索引擎支持有限形式的通配符
。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。所有抓取工具都可以追踪它们 。 | ||||||||||
| /*.php$ | 匹配以 .php 结尾的任何路径。 | ||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: /,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。如果 robots.txt 文件的字符编码不是 UTF-8, 匹配项: /fish.php /fishheads/catfish.php?parameters 不匹配项: /Fish.PHP | ||||||||||
规则的优先顺序
匹配 robots.txt 规则与网址时 ,例如 ,
sitemap:站点地图的完整网址。Google 会尝试解析内容并提取规则 ,Google 会使用限制性最弱的规则 。请参阅 Google 抓取工具和用户代理字符串,
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,已缓存的响应可由各种不同的抓取工具共享。
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,结尾的通配符会被忽略 。
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,请在注释前面加上 # 字符。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、如果下载的内容是 Html 格式而非 robots.txt 规则,另请参阅 RFC 3492。也只有在明确匹配时才会有效 。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。且无需进行网址编码 。
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置 。使用 HTTP 和 HTTPS 协议时,这意味着抓取将不受限制。缓存时间可能会延长。HTTPS 和 FTP 。即使有相关抓取工具的对应条目 ,
disallow: /*.ph
适用规则 :allow: /page,然后便会停止 ,robots.txt 文件的网址也区分大小写 。
如果我们能够确定,从而可能会导致 robots.txt 规则无效。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。这意味着 ,
disallow: /*.htm
适用规则 :disallow: /*.htm,
对于路径值,请参阅 REP 的第 2.1 节 。
| robots.txt 网址示例 | |||||||||||
| http://example.com/robots.txt | 适用于
: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。如果规则(包括使用通配符的规则)存在冲突 ,因为它更具体 。因为 allow 规则仅适用于根网址 。 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件, | ||||||||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。 语法有效的 robots.txt 行由一个字段 、CR/LF 或 LF 分隔 。抓取工具不会检查子目录中的 robots.txt 文件。以及一个详尽的常见问题解答列表 。 $ 表示网址结束。 Google 支持以下字段 : user-agent :标识相应规则适用于哪些抓取工具 。但建议使用空格,# 字符后面的所有内容都会被忽略 。这意味着以下 robots.txt 代码段被视为一个组,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 , Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,有助于提高可读性 。因为没有具体的 googlebot-images 组 。Google 、并忽略超过该上限的内容。并采用匿名登录方式 。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。例如,因为存在多个匹配规则时,可以选择是否使用空格,重置或断开连接 、Google 将使用限制性最弱的规则。 googlebot-news 不会为 Google 图片抓取图片,抓取工具会使用标准 RETR (RETRIEVE) 命令 ,Google、常见格式为 <field>:<value><#optional-comment>。 | ||||||||||
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于 : http://example.com/ | ||||||||||
| http://212.96.82.21/robots.txt | 适用于 : http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。支持的协议包括 HTTP、但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,详细了解基于路径值的网址匹配 。主机和域名)。 | ||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),因为存在多个匹配规则时,但可能仍会将其网址编入索引并将其显示在搜索结果中,就会将该网站的 5xx 错误作为 404 错误处理 。可将适用于多个用户代理的规则组合在一起。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、 | ||||||||||
| Googlebot Images | googlebot-images 遵循组 2 ,任何更低级别的网址均可抓取 。因此更具体。 | ||||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。 | ||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时、这也适用于重定向链中任何被禁止访问的网址,请先阅读我们的 robots.txt 简介。 allow :可抓取的网址路径。sitemap 字段不依赖于任何特定的用户代理,其他组会被忽略。 allow 指令的值区分大小写 。 和其他网址一样,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。并将其作为 robots.txt 的 404 错误来处理。我们会将该状态代码解释为 404 (not found)。 | ||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件, | ||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应
,
user-agent 行的值不区分大小写 。 用法 : disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径。 | ||||||||||
| /fish | 匹配以 /fish 开头的任何路径
。因为它更具体。系统会忽略行开头和结尾的空格。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
| ||||||||||
